quinta-feira, 28 de março de 2019

Como resolver o problema da versão do Android na publicação na Google Play

Erro acusado pelo Google Play:
No momento o nível desejado da API do seu app é 21. No entanto, esse nível precisa ser de pelo menos 26 para que o app use as APIs mais recentes, que contam com otimizações de segurança e desempenho. Altere o nível desejado da API do seu app para pelo menos 26.
Esse erro acontece porque a configuração "Target Android version" fica marcado como "Use Compile using SDK version" e por isso o Xamarin coloca automaticamente a configuração da versão mínima, que no caso da imagem abaixo é a Android 5.0 (API Level 21).

Para resolver é só marcar a configuração solicitada pela Google Play ou superior.

Precisa ficar igual a imagem acima

Essa configuração também pode ser feita diretamente no AndroidManifest.xml no parâmetro targetSdkVersion que atualmente é obrigatório a Api 26 ou superior: 
<uses-sdk android:minSdkVersion="21" android:targetSdkVersion="26" />


Nenhum comentário:

Postar um comentário